[squid-users] Invalid Reponse on Squid 3.0 and 3.1 but not 2.6

From: <Alexander.Eck_at_Heidelberg.de>
Date: Fri, 8 Jun 2012 08:36:33 +0000

Hi everyone,

I'm receiving an error page
"Invalid response"
When accessing a specific website.

I'm running  squid-3.0.STABLE9-1.el5 on Centos 5.7. The website is the following:


just press the button "Recherche starten" and you will see the error page.

Looking at the cache.log file I see no error or something.

I have another squid-2.6  on another Centos 5.7 machine. When using this  the webpage is displayed correctly.

For testing purposes I upgraded my squid 2.6 to squid-3.1.14-1.el5 and tried to access the webpage again.
Now I'm receiving the same error page as with squid 3.0.
Fortunately in cache.log I'm receiving the following Warning now:

WARNING: HTTP: Invalid Response: Bad header encountered from http://register.dpma.de/DPMAregister/marke/experte.kopf.form AKA register.dpma.de/DPMAregister/marke/experte.kopf.form

I alrdy tried the following on my squid 3 .0 and 3.1:

1. Adding the following to squid.conf:
a. Acl dpma dstdomain register.dpma.de
b. Request_header_access Accept-Encoding allow dpma
2. Deleting the above and editing:
a. Acl dpma dstdomain register.dpma.de
b. Cache deny dpma

Can anybody please help me here? I'm not sure why the webpage is displayed on 2.6 correctly, but not on 3.0 and 3.1 ?
My guess is that the header is corrupt, but shouldn't my first change (Request_header_access etc. ) get this working ?

Best Regards


Mit freundlichen Grüßen

Alexander Eck

Stadtverwaltung Heidelberg
Personal- und Organisationsamt
Abteilung Informationsverarbeitung

Telefon 06221/ 58-11161
Received on Fri Jun 08 2012 - 08:36:41 MDT

This archive was generated by hypermail 2.2.0 : Fri Jun 08 2012 - 12:00:02 MDT